Members | Sign In
Legacy MOVI User Community Forum (readonly) > MOVI Question & Answers
avatar

Updating MOVI Firmware - SD card size of 15.9 MB, no .img file

posted Jan 10, 2017 03:11:55 by P87_Robotics
Hi everyone,

I am running into some technical issues while trying to update MOVI's firmware. I have been following the instructions in the updated user's manual, for Windows installation (I am using a Windows 10 PC). I have gotten Win32 Disk Imager up and running, however, when I attempt to select MOVI's image file, it does not appear in the directory. In addition, the SD card appears to be only 15.9 MB in capacity, which seems rather unlikely, due to it being fully functional when installed on the board. Does anybody else run into this problem as well?

Regards,

Ian
page   1
5 replies
avatar
P87_Robotics said Jan 10, 2017 03:13:04
Also, here is a screenshot of the SD card when inserted into the computer.

http://imgur.com/a/g872A

Thanks,

Ian
avatar
GeraldFriedland said Jan 12, 2017 17:01:24
That's very odd. I have never observed this behavior.

Having said that: Can you run DiskImager and other tools?

The Instructable we wrote on Spanish provides a lot more detail (just ignore the part about the Spanish models):
http://www.instructables.com/id/Connection-Less-Spanish-Speech-Recognition-and-Syn/

Let me know what happens when you try Step 5 and/or Steps 7,8.

Hope that helps,
Gerald
[Last edited Jan 12, 2017 17:01:54]
avatar
P87_Robotics said Jan 13, 2017 03:27:52
Hi Gerald,

I can run DiskImager and OSFMount with no issues on my computers, both a Windows 10 PC and a Win 7 Laptop.

Unfortunately, after following the steps detailed in the instructable, the SD card was still only 15.9MB is size. It appears to be formatted as a FAT card. Not too sure if that makes any difference...

I have tried using my Win 7 computer to update the firmware, but it also shows up as 15.9MB. In both instances, the SD card was labeled as the "G:" drive.

I hope I'm not missing any other steps, as I have followed all of them up until the backing up of the card (where I'm currently stuck at). Hopefully there is some kind of solution :)

Thanks!
Ian
avatar
P87_Robotics said Jan 13, 2017 03:51:47
One quick update:

I tried updating the second MOVI board that I just got in the mail, and I am having the exact same issue with it.

Is it possible that I am only able to see one partition partition for whatever reason?

Thanks,

Ian
avatar
GeraldFriedland said Jan 14, 2017 18:27:21
Seeing only one partition is exactly what happens. It's a bug in Windows. Again, I am referring you to our 1.10 manual and our before-mentioned Instructable. Alternatively, use a Mac or a Linux machine then everything should work as expected.

What to double check here is: Did you backup the entire card (4GB) or only the boot partition 15MB? It sounds to me that you accidentally only backed up the first partition.

Gerald
[Last edited Jan 14, 2017 20:29:51]
Login below to reply: