Members | Sign In
MOVI User Community Forum > MOVI Question & Answers
avatar

Just got my Movi but the Lightswitch example is not working

posted Mar 26, 2017 00:12:49 by Budreaux1973
This may be a bit long-winded, but I want to explain exactly what I have tried. I know there was a post on the forum here with a similar problem, but there was never really a resolution to that post. Anyway, back to the problem.

I am using an Arduino R3 (Ver 1.6.4), Movi library is 1.13.0, and I have an external LED across D13 and GND (it lights when the Arduino is plugged in, so I know it is getting power and is working). I loaded the lightswitch example and connected everything (using external 12V 2A power first, then plugging in the USB as instructed in the start-up guide). Upon power-up, I get the message "Movi Booting" then "Movi is ready" and finally "the call sign is Arduino". I then say "arduino" and get two high frequency beeps. I say "let there be light" and get two low frequency beeps but nothing happens (no LED light) and Movi does not give any responses. I have tried to say different things (stuff like - where's my cat, bark, just say something) and get the same result. Now for the weird part. I tried to upload new examples, but it doesn't seem like Movi is recognizing the new programs. I get the uploading completed message from arduino but not the output expected from movi. For example, when I try uploading the example VersionCheck, Movi still gives the same start-up responses but does not execute the program on the arduino (does not say the version info). Anyone got any idea what's going on?
page   1
14 replies
avatar
GeraldFriedland said Mar 26, 2017 21:04:59
This sounds like a problem with the connection between MOVI and the Arduino. When you say you use v1.6.4 -- is that the IDE you are referring to?

The Arduino 1.6 IDE is fatally buggy. I recommend using either 1.0.6 (the old version) or 1.8.1 (the newest version).

Let me know if that helps,
Gerald
avatar
Budreaux1973 said Mar 27, 2017 03:02:20
Gerald,

I updated the Arduino IDE to 1.8.2. I reloaded the sketch and it appears to be functioning properly now. I guess we can say for sure that 1.6.4 is definitely not the IDE to use with Movi. Thanks.

Dave
avatar
Kenny Cheong said May 21, 2017 04:16:54
I had exactly the same problem.

I was using Arduino IDE 1.8.2

I was using an Arduino Leonardo R3.

I tired 2 Leonardo boards and still no success.
I switched to a Arduino Uno R3 compatible and I got success.

I am not sure what is going on, but I have always found serial on leonardo a little bit finiky.

I would like to know if you have done any tests with Arduino Leonardo and had similar experiences?
avatar
Bertrand said May 23, 2017 01:47:03
We have tested the Leonardo and it works fine but the problem with the Leonardo is that the USB can be switched to host mode. This can even brick the Leonardo! So 'finiky' is quite politically correct...

We posted an example earlier pointing this out:
http://www.audeme.com/forum.html#/20160105/using-a-movi-with-an-arduino-leonardo-as-a-ke-5137824/


Gerald
[Last edited May 23, 2017 01:52:50]
avatar
SteveLawson said Jun 23, 2017 01:34:05
Hello, I have the exact same problem as described above.
Movi doesn't seem to understand me. I'm Canadian eh, but shouldn't speak that much different from our friends to the South.

MOVI failed at the step below in the manual but previously I had the correct MOVI beeps.

12. Speakers should say “and there was light” and LED on Arduino board turns on.
Please note that Arduino’s onboard LED might be a bit hidden below the MOVI
shield. For better visibility, connect an LED to Arduino port D13 (+) and GND (-).

At the step above, the D13 LED doesn't light although if flashed during download and boot up. I also don't get the "and there was light!" reply back. Even changing the recognizer.callSign("Arduino") to another word and doing a CTRL U then powering down and back up results in MOVI booting up saying the call sign is "Arduino". So no change to the call sign from the edit I made and uploaded.

Below is the output from the LowLevelInterface interface sketch.
Arduino Ready.
Type 'HELP' for a list of commands.
MOVIEvent[102]: MOVI(tm) v1.10 (c) 2014-2016 Audeme LLC.

Steps Taken...
I upgraded my IDE to 1.8.3 then rebooted the PC and toggeled the Arduino power and re-uploaded the LightSwitch sketch.

Hardware...
Arduino manufacturer - Oseep Model Mega 256 R3 Plus with J1 open and J2 and J3 closed.
I'm using a good quality lab power supply set at 9 volts into Vin and the combined Arduino and MOVI are drawing 200 ma.

While typing this message, MOVI said a few times "There is a lot of noise in the room".

Thanks for any help you can provide.
avatar
GeraldFriedland said Jun 26, 2017 01:37:09
That's very very strange.

I did have problems with Osepp boards before but I am not sure this is the problem here. First of all: When MOVI returns with <beep><beep> after you say the call sign, MOVI works. To get to that beep, there needs to be a full recognition cycle... So the problem is the communication between MOVI and Arduino.

It is strange though that you see the Output form the LowLevelInterface. In order to see that output, MOVI has to communicate with the Arduino. Here is one thing to try:

in that LowLevelInterface can you enter "SAY hello"? This should result in MOVI saying "hello" using the synthesizer. If that works then there is really no reason for the LED example not to work...

Gerald
avatar
SteveLawson said Jun 26, 2017 04:08:48
Thanks for your help Gerald.

Entering SAY Hello into the Serial Monitor results in no sound from MOVI until after I X out of the Serial Monitor. At that point, MOVI says something that sounds like "Helloabou". This happens when I hit Enter on the keyboard or click the Send button.

MOVI is happier when I use PuTTY. Using PuTTY, MOVI says "Hello" after I hit the Enter key.

I re-downloaded the unedited LightSwitch sketch and the LED still doesn't come on. It flashes once when I start the download, flashes all through the download process then flashes twice at the end of the download but it does not get turned on after saying let there be light.

I say Arduino and MOVI replies with 2 high freq. chirps.
I say let there be light and MOVI replies with 2 lower freq. chirps but the LED doesn't turn on.
I say Arduino and MOVI replies with 2 high freq. chirps.
I say go dark and MOVI replies with 2 lower freq. chirps but no change the the LED status (still off).

It may be intersting that VOCABULARY returns...
MOVIEvent[003]: 0 LET THERE BE LIGHT
MOVIEvent[003]: 1 GO DARK

Thank you.
avatar
SteveLawson said Jun 26, 2017 04:26:09
I think it understands me but still no LED action...

MOVIEvent[200]: CALLSIGN DETECTED
MOVIEvent[140]: ACTIVELISTEN
MOVIEvent[141]: END ACTIVELISTEN
MOVIEvent[201]: LET THERE BE LIGHT
MOVIEvent[202]: #0
MOVIEvent[200]: CALLSIGN DETECTED
MOVIEvent[140]: ACTIVELISTEN
MOVIEvent[141]: END ACTIVELISTEN
MOVIEvent[201]: GO DARK
MOVIEvent[202]: #1
MOVIEvent[150]: SPEAKING
MOVIEvent[151]: END SPEAKING
avatar
GeraldFriedland said Jun 26, 2017 15:38:17
Steve,

MOVI clearly understands you, as shown by the event trace (which was the next thing I was going to ask you for). The hint that you need to exit Serial Monitor before MOVI start to speak and that the speech is something that is intermingled between something you sent and some other string, is a clear indication that something with the serial connection in fishy.

It seems there is some more debugging to do.

1) Have you tried to disconnect MOVI from your computer after programming it? I wonder if there is something in the interplay between MOVI, Arduino, and that USB connection. After all, MOVI did something after you closed the Serial Monitor.
2) Have you tried an original Arduino board (instead of Osepp?) Again, I have had problems with Osepp and it's not one of the boards we reported as working.

Third, but assumed obvious, question: Is your Arduino IDE >=1.8 and MOVI Library 1.13?

Sorry for the trouble but it's something that hasn't been reported yet...

Gerald
avatar
SteveLawson said Jun 27, 2017 04:02:55
Hello, just out of curiosity, I changed the pin number in the LightSwitch code from 13 to 12 and connected the LED to D12. I uploaded the code and ran it but it still didn't work.
I have since returned the LED pin connections and sketch pins back to 13.

To answer your question #1, no I hadn't tried that.
I removed the USB cable from the PC and Arduino, gave the speech commands but the Led didn't turn on.

Question #2, no I only own the Osepp board.

Q3, I don't know if this helps or not but the versionCheck sketch doesn't say anything on my board.
After downloading it, it doesn't say anything.
Toggling the Arduino power results in MOVI saying
MOVI is booting, MOVI is ready, the callsign is Arduino but nothing after that.
My Arduino IDE is version 1.8.3 and MOVI library is version 1.13.

As a further debug aid, I removed the MOVI shield not to damage or confuse it, connected my same resistor to GND and D13 and uploaded the Arduino Blink sketch. Both the on board and my external LED blinked. This Arduino board was brand new, bought just to run MOVI so I wanted to confirm that D13 could be S/W controlled. The Blink sketch confirmed that.

Time to buy an original Arduino Mega?

I'm sorry to take up so much of your time.
avatar
GeraldFriedland said Jun 28, 2017 16:46:22
Thanks for doing so much debugging work. At this point it is quite clear to me that there is a programming incompatibility with SoftwareSerial on OSEPP.

I filed an issue: https://github.com/audeme/MOVIArduinoAPI/issues/22

If you want to continue debugging, there are two more things you can try:
1) Try to use a hardware serial port, if your board has one. So not 10/11 but uart2. The MOVI library supports that. You would have to cable it from the jumpers in MOVI, as described in our manual.
2) Since you mentioned using PUTTY. Try connecting a USB-serial cable to pin 10/11 of MOVI to snoop into the communication between your "Arduino" board and MOVI.

But honestly, getting an original Arduino board is most likely your quickest solution.

Thank you,
Gerald

P.S.: Can you specify exactly what type of OSEPP board you have?
[Last edited Jun 28, 2017 16:46:47]
avatar
SteveLawson said Jul 13, 2017 00:29:50
Hello Gerald, I took delivery of a genuine Arduino Mega since we last spoke but have the exact same problem I previously had with the Osepp Arduino. Movi does everything it should short of turning on the external led and saying the response "and there was light" when running the LightSwitch sketch. The external led flashes during download and when running the Blink sketch. Is it time for a new Movi board yet?

I didn't do the debugging you requested above because it was a little over my head.

Setup -
Motherboard Genuino Mega 2560
IDE Version 1.8.3
No IDE errors on download
Library Version 1.13
Power Source, Adjustable Lab Power Supply set at 12V capable of supplying 5A

Thank you, Steve.
[Last edited Jul 13, 2017 10:30:53]
avatar
GeraldFriedland said Jul 17, 2017 21:55:30
Yes. Please contact us at the "contact us" and we will arrange for a new MOVI board.

Gerald
avatar
SteveLawson said Jul 18, 2017 01:48:36
Will do.
Thank you Gerald
Login below to reply: